Задать вопрос
25 марта, 12:59

Дано n последовательных натуральных чисел начиная с 1. Написать программу, вычисляющую их среднее арифметическое

+3
Ответы (1)
  1. 25 марта, 15:44
    0
    Import java. util. Scanner;

    import java. io.*;

    public class Sred {

    public static void main (String[] args) {

    Scanner in = new Scanner (System. in) ;

    int n;

    System. out. print ("n=") ;

    n = in. nextInt () ;

    int[] a = new int[n];

    int sum = 0;

    for (int i = 0; i < n; i++) {

    a[i] = in. nextInt () ;

    sum + = a[i];

    }

    float sred = (float) sum / n;

    System. out. printf ("Среднее арифметическое: %.1f / n", sred) ;

    }

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано n последовательных натуральных чисел начиная с 1. Написать программу, вычисляющую их среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)