Задать вопрос
19 октября, 21:51

Помогите сделать задание в С++

В трехзначном числе x зачеркнули его последнюю цифру. Когда в оставшемся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n. По заданному n найти число x (значение n вводится с клавиатуры, 1 ≤ n ≤ 999 и при этом число единиц в n не равно нулю).

+4
Ответы (1)
  1. 19 октября, 22:50
    0
    В программе предполагается, что "0" (если это средняя цифра числа) не отбрасывается.

    Например: 105 ⇒ 10 ⇒ 01 ⇒ 501 (а не 105 ⇒ 10 ⇒ 1 ⇒ 51).#include

    using namespace std;

    int main ()

    {

    int n, n1, n2, n3, x;

    cin >> n;

    n1 = n / 100;

    n2 = n / 10 % 10;

    n3 = n % 10;

    x = n3*100+n2*10+n1;

    cout << x <
    system ("pause") ;

    }

    Пример:

    21

    120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите сделать задание в С++ В трехзначном числе x зачеркнули его последнюю цифру. Когда в оставшемся двузначном числе переставили цифры, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В трехзначном числе x зачеркнули его последнюю цифру. когда в оставшимся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)
В трехзначном числе x зачеркнули его вторую цифру. Когда к образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x (значение n вводится с клавиатуры).
Ответы (1)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)