Задать вопрос
10 августа, 14:33

Составить программу для вычисления длин высот треугольника, у которого длины сторон abc?

+5
Ответы (1)
  1. 10 августа, 18:14
    0
    Uses crt;

    var a, b, c: integer;

    h1, h2, h3, p, s:real;

    begin

    readln (a) ;

    readln (b) ;

    readln (c) ;

    p: = (a+b+c) / 2;

    s:=sqrt ((p-a) * (p-b) * (p-c)) ;

    h1:=2*s/a;

    h2:=2*s/b;

    h3:=2*s/c;

    writeln (h1) ;

    writeln (h2) ;

    writeln (h3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для вычисления длин высот треугольника, у которого длины сторон abc? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
Составьте программу для вычисления длин высот треугольника, у которого длины сторон a, b, c (a, b, c вводятся с клавиатуры).
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)