Задать вопрос
10 августа, 15:47

Составить программу в паскаль: Найти подпоследовательность максимальной длины подряд идущих чисел массива равных между собой

+2
Ответы (1)
  1. 10 августа, 16:47
    0
    Const

    N = 33;

    Var

    A:array[1 ... N] of integer;

    i, k, M, d:integer;

    Begin

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (N div 10+1) ;

    Write (' ', A[i])

    End;

    WriteLn;

    k:=1;

    d:=0;

    For i:=1 to N-1 do

    if (A[i]=A[i+1]) then k:=k+1

    else

    Begin

    if k>d then

    Begin

    d:=k;

    M:=i;

    End;

    k:=1;

    End;

    if d>1 then WriteLn ('Искомая последовательность начинается с элемента №', M-d+1,', и заканчивается элементом №', M,'')

    else if d>0 then WriteLn ('В массиве нет, стоящих рядом, равных чисел')

    else WriteLn ('Все числа в последовательности равны') ;

    End.

    Пример:

    Исходный массив: 1 1 1 1 1 2 2 1 3 2 0 3 1 3 0 3 3 0 0 1 3 1 1 2 3 0 1 1 2 2 1 0 0

    Искомая последовательность начинается с элемента №1, и заканчивается элементом №5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскаль: Найти подпоследовательность максимальной длины подряд идущих чисел массива равных между собой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)