Задать вопрос
26 декабря, 11:58

Составить программу на паскале. Вычислить корни квадратного

уравнения, заданного коэффициентами A, B,

C (предполагается, что а0 и что дискриминант

уравнения неотрицателен)

+5
Ответы (1)
  1. 26 декабря, 14:22
    0
    Var a, b, c, D, x1, x2:real;

    begin

    write ('Введите коэффициенты a, b, c: ') ;

    readln (a, b, c) ;

    D: = b*b-4*a*c;

    if D>0 then

    begin

    x1: = (-b-sqrt (D)) / 2/a;

    x2: = (-b+sqrt (D)) / 2/a;

    writeln ('Два корня: ', x1,' и ', x2)

    end;

    if D=0 then

    begin

    x1:=-b/2/a;

    writeln ('Один корень: ', x1)

    end;

    if D<0 then writeln ('Корней нет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на паскале. Вычислить корни квадратного уравнения, заданного коэффициентами A, B, C (предполагается, что а0 и что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы