Задать вопрос
19 июля, 07:10

1. Вычислить корни квадратного уравнения с заданными коэффициентами а, b, с

на турбо паскале

+2
Ответы (1)
  1. 19 июля, 10:24
    0
    Program sqr;

    Var a, d, b, c, x1, x2:Real;

    Begin

    WriteLn ('Введите A, B и C') ;

    ReadLn (a, b, c) ;

    d:=Sqr (b) - 4*a*c;

    x1: = (-b - Sqrt (d)) / (2*a) ;

    x2: = (-b + Sqrt (d)) / (2*a) ;

    If x1 < = x2 then

    WriteLn ('X1 = ', x1,' X2 = ', x2)

    else

    WriteLn ('X1 = ', x2,' X2 = ', x1) ; ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Вычислить корни квадратного уравнения с заданными коэффициентами а, b, с на турбо паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Что является составляющими языка? а) Синтаксис; б) Семантика; в) Грамматика; г) Морфология. 2. Средой Что есть визуального программирования? а) Турбо Паскаль; б) Турбо в Excel; в) Турбо Дельфи; г) базовые. 3.
Ответы (1)
Составить программу на паскале. Вычислить корни квадратного уравнения, заданного коэффициентами A, B, C (предполагается, что а0 и что дискриминант уравнения неотрицателен)
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
В Турбо Паскале ... Вычислить следующее выражение при X = 10, Y = 3: Z = (sin37+cos73+tg23) / (x^2-2XY^2+Y^4) ^ - возведение в степень.
Ответы (1)
Создать программы в Паскале: 1. Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел. 2. Вычислить расстояние между двумя точками с заданными координатами (х1, у2) и (х2, у2)
Ответы (1)