Задать вопрос
1 октября, 11:21

Вам даны число N и цифра D. Выведите все N-значные числа, которые не содержат цифру D, в возрастающем порядке.

+5
Ответы (1)
  1. 1 октября, 12:53
    0
    Var a, b:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    writeln ('Введите цифру') ;

    read (b) ;

    if ((a mod 10) b) and ((a div 10) b) and (a<100) then begin

    a:=a+1;

    write (" ", a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вам даны число N и цифра D. Выведите все N-значные числа, которые не содержат цифру D, в возрастающем порядке. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке. Формат входных данных В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. "Входные данные" Вводятся два числа. "Выходные данные" Выведите ответ на задачу.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)