Задать вопрос
2 ноября, 21:53

Составить программу в Паскале:

Найти наибольшее целое n такое что:

a) 3n^4-730n<5

b) e^n-1000Ln*n<=10

+5
Ответы (1)
  1. 2 ноября, 23:56
    0
    1) Если использовать последний Паскаль АВС, который умеет вычислять степень (Power), то вот вариант программы:

    var

    n:integer;

    s:real; {вообще, он целый, но мой компилятор не пропускает, почему-то считает, что результат вычислений будет real}

    begins:=0;

    n:=1;

    while s<5 do

    begin

    s:=3*power (n, 4) - 730*n; {для старого Паскаля напиши так: s:=3*sqr (sqr (n)) - 730*n}

    n:=n+1

    end;

    writeln (n)

    end.

    2)

    var n, s:real;

    begin

    s:=0;

    n:=1;

    while s<=10 do

    begin

    s:=exp (n) - 1000*Ln (n) ;

    n:=n+1

    end;

    writeln (n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскале: Найти наибольшее целое n такое что: a) 3n^4-730n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Что такое алгоритм? Что такое исполнитель? Что такое среда исполнителя? Что называется командой? Что такое формальный исполнитель? Что такое неформальный исполнитель? Назовите режимы работы исполнителя Что такое система команд исполнителя?
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)