Задать вопрос
2 ноября, 23:27

Стоимость доставки самолетом 1 кг. груза составляет 30 рублей. Для каждого из N пассажиров введите вес багажа, который он перевозит, подсчитайте, сколько каждый пассажир должен заплатить за перевозку своего багажа. Вычислите также общий вес груза, перевозимого пассажирами. (паскаль)

+4
Ответы (1)
  1. 3 ноября, 02:35
    0
    Var

    i, v, n, vm: longint;

    ar: array of integer;

    begin

    vm : = 0;

    readln (n) ;

    setlength (ar, n) ;

    for i : = 1 to n do

    begin

    read (v) ;

    ar[i - 1] : = v * 30;

    vm : = vm + v;

    end;

    writeln;

    for i : = 1 to n do write (ar[i - 1], ' ') ;

    writeln;

    write ('Общий вес: ', vm) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Стоимость доставки самолетом 1 кг. груза составляет 30 рублей. Для каждого из N пассажиров введите вес багажа, который он перевозит, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Определить сколько бутербродов можно сделать. Если выдается: H - общий вес хлеба H1 - хлеб на один бутерброд M - общий вес масла M1 - вес масла на один бутерброд K - общий вес колбасы K1 - вес колбасы на один бутерброд B - общее количество
Ответы (1)
Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)