Задать вопрос
9 сентября, 17:55

Определить сколько бутербродов можно сделать. Если выдается:

H - общий вес хлеба

H1 - хлеб на один бутерброд

M - общий вес масла

M1 - вес масла на один бутерброд

K - общий вес колбасы

K1 - вес колбасы на один бутерброд

B - общее количество бутербродов

Например На бутерброд

H - 1000 H1 - 100

M - 600 M1 - 50

K - 500 K - 50

B - 10

H - 0

M - 100

K - 0

+5
Ответы (1)
  1. 9 сентября, 18:03
    0
    Var h, h1, m, m1, k, k1, b:integer;

    begin

    write ('h, h1: ') ; readln (h, h1) ;

    write ('m, m1: ') ; readln (m, m1) ;

    write ('k, k1: ') ; readln (k, k1) ;

    if h div h1 < m div m1

    then b:=h div h1 else b:=m div m1;

    if k div k1 < b then b:=k div k1;

    writeln ('b = ', b) ;

    end.

    Пример:

    h, h1: 1000 100

    m, m1: 600 50

    k, k1: 500 50

    b = 10

    С помощью h div h1 (m div m1, k div k1) определяется на сколько бутербродов хватит хлеба, масла или колбасы соответственно. Из этих количеств выбирается минимальное значение. В примере: хлеба хватит на 1000 div 100 = 10 бутербродов, масла - на 600 div 50 = 12; колбасы - на 500 div 50 = 10. Значит, из данного количество продуктов можно сделать 10 полноценных бутербродов.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить сколько бутербродов можно сделать. Если выдается: H - общий вес хлеба H1 - хлеб на один бутерброд M - общий вес масла M1 - вес ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Цена на хлеб составляет N руб. за булку хлеба. Прогнозируемая инфляция составляет 0,3% в месяц, Вычислите сколько средств (в руб.) тратит семья на покупку хлеба в год, если ежедневно семья покупает 2 булки хлеба
Ответы (2)
Утром, в продуктовый магазин привезли К булок белого хлеба по цене 25 рублей и В булок черного хлеба по цене 23,50 рублей. Определить выручку магазина от продажи хлеба.
Ответы (1)
Нужно составить программу ветвления по информатике! Для задачи: На приеме у педиатра производится измерение роста и всеса грудных детей в возрасте до трех месяцев. Компьютер определить рост и вес месяц назад.
Ответы (1)
При регистрации в компьютерной системе, используемой при проведении командной олимпиады, каждому ученику выдается уникальный идентификатор - целое число от 1 до 1000.
Ответы (1)
1) ) При регистрации в компьютерной системе, используемой при проведении командной олимпиады, каждому ученику выдается уникальный идентификатор - целое число от 1 до 1000.
Ответы (1)