Задать вопрос
16 октября, 10:26

Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить,

сколько он будет стоить через N лет. (Pascal)

Пример:

Введите стоимость стола: 35000

Введите кол-во лет: 5

Стоимость стола на конец 1 года: 30800.000 рублей

Стоимость стола на конец 2 года: 27104.000 рублей

Стоимость стола на конец 3 года: 23851.520 рублей

Стоимость стола на конец 4 года: 20989.338 рублей

Стоимость стола на конец 5 года: 18470.617 рублей

+4
Ответы (1)
  1. 16 октября, 13:17
    0
    Program Schet;

    var

    i:integer;

    stoimost:real;

    godi:integer;

    Begin

    Write ('Введите стоимость стола: ') ;

    Readln (stoimost) ;

    Write ('Введите количество лет: ') ;

    Readln (godi) ;

    for i:=1 to godi do

    Begin

    stoimost-=stoimost*0.12;

    Writeln ('Стоимость стола на конец ' + i + ' года: '+stoimost) ;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Написать в тетради программу на Pascal: Спросить у пользователя три числа. Вывести сумму чисел, среднее значение. Пример: Введите а: 5 Введите b:4 Введите c:3 Сумма: 12 Среднее: 6
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)