Задать вопрос
22 июня, 06:36

Построить блок-схему и написать программу

1. Вычислить S=1+2+3+4+ ...+N

2. Для данного N составить алгоритм вычисления факториала N!=1*2*3* ...*N

+1
Ответы (1)
  1. 22 июня, 09:30
    0
    1.

    program z;

    var n, i:integer; s:real;

    begin

    writeln ('Введите число n') ; readln (n) ;

    for i:=1 to n do

    begin

    s: = (n * (n+1)) / 2; end;

    writeln (s) ;

    end.

    2. program z2;

    var s, i, n:integer;

    begin

    writeln ('Введите число n ') ; readln (n) ;

    s:=1;

    for i:=1 to n do s:=s*i;

    write (s) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Построить блок-схему и написать программу 1. Вычислить S=1+2+3+4+ ...+N 2. Для данного N составить алгоритм вычисления факториала N!=1*2*3* ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно. 2. Составить блок - схему кипячения чайника. 3. Составить алгоритм сбора яблок в саду.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составить и зафиксировать в форме блок-схемы алгоритм вычисления факториала числа
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)