Задать вопрос
27 октября, 19:03

Дано натуральное

число. Верно ли, что в его записи встречается цифра 3?

+2
Ответы (2)
  1. 27 октября, 19:30
    0
    Если я не ошибаюсь, то натуральные числа идут от 1-до бесконечности! А 0 это не натуральное! Натуральное число можно узнать при счете например яблок!0 яблок значит их совсем нету а если 2 яблока уже есть!
  2. 27 октября, 22:54
    0
    Program p;

    var x:longint;

    t:boolean;

    begin

    Write ('Введите натуральное число, х = ') ;

    Readln (x) ;

    While x0 do

    begin

    If x mod 10 = 3 then

    t:=true;

    X:=x div 10;

    end;

    If t=true then

    Writeln ('Да, встречается') else

    Writeln ('Нет, не встречается') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Верно ли, что в его записи встречается цифра 3? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)