Задать вопрос
31 января, 10:49

Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b

≥ с, и заменить их абсолютными

значениями, если это не так.

+2
Ответы (1)
  1. 31 января, 13:58
    0
    Var a, b, c:real;

    Begin

    write ('Введите a, b, c: ') ; readln (a, b, c) ;

    if (a>=b) and (b>=c) then

    Begin

    a:=a*2;

    b:=b*2;

    c:=c*2;

    End

    else

    Begin

    a:=abs (a) ;

    b:=abs (b) ;

    c:=abs (c) ;

    End;

    writeln ('a = ', a:2:2,' b = ', b:2:2,' c = ', c:2:2) ;

    readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b ≥ с, и заменить их абсолютными значениями, если это не так. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
Ребят, помогите с информатикой! задача: Ввести три числа А В и С. Отрицательные числа заменить их абсолютными значениями. Желательно ассемблер
Ответы (2)
Даны четыре действительных числа a, b, c, d. Если произведение abбольше произведения cd, то удвоить числа a и b, в противном случае удвоить числа c и d
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)