Задать вопрос
20 июня, 04:13

Ребят, помогите с информатикой!

задача:

Ввести три числа А В и С. Отрицательные числа заменить их абсолютными значениями.

Желательно ассемблер

+3
Ответы (2)
  1. 20 июня, 04:49
    0
    Если нужно что-то исправить, говорите.

    var

    A, B, C:real;

    Begin

    Write ('Введите число A: ') ;

    Read (A) ;

    Write ('Введите число B: ') ;

    Read (B) ;

    Write ('Введите число C: ') ;

    Read (C) ;

    if A<0 then

    Begin

    A * = - 1;

    Write ('|A| = ' + A)

    End;

    if B<0 then

    Begin

    B * = - 1;

    Write ('|B| = ' + B)

    End;

    if C<0 then

    Begin

    C * = - 1;

    Write ('|C| = ' + C)

    End;

    End.
  2. 20 июня, 06:08
    0
    Var a, b, c; real;

    begin

    readln (a, b, c) ;

    if a<0 then a:=abs (a) ;

    if b<0 then b:=abs (b) ;

    if c<0 then c:=abs (c) ;

    writeln (a, b, c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, помогите с информатикой! задача: Ввести три числа А В и С. Отрицательные числа заменить их абсолютными значениями. Желательно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b ≥ с, и заменить их абсолютными значениями, если это не так.
Ответы (1)
1) Ввести 2 числа, заменить число суммой чисел, а большее произведением. 2) Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3) Журнал стоит k руб. Какую сдачу получит покупатель если у него в руб.
Ответы (1)
Предложено описание термина, не связанного с информатикой. Определите этот термин. Удалите из него одну букву так, чтобы получился термин, связанный с информатикой. В ответ запишите только полученное слово в именительном падеже.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)