Задать вопрос
18 сентября, 22:33

Помогите написать алгоритм нахождения суммы положительных среди 10 вводимых.

+3
Ответы (1)
  1. 19 сентября, 01:04
    0
    Program BiFi;

    Var a:array[1 ... 10] of real;

    s, i:real;

    Begin

    s:=0;

    for i:=1 to 10 do begin readln (a[i]) ;

    if a[i]>0 then s:=s+a[i];

    end;

    writeln (s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать алгоритм нахождения суммы положительных среди 10 вводимых. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Помогите с паскалем 1. написать алгоритм нахождения максимального среди 4 целых чисел. 2. написать алгоритм проверки: имеются ли среди трех целых чисел два положительных значения. 3.
Ответы (1)
на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел. Печать результата по вводу 0 (используя цикл while т. е. предусловие).
Ответы (1)
6. Составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел. N не больше 10
Ответы (1)
Составить алгоритм и написать программы нахождения произведения чисел, модуль которых меньше 10 из 20 вводимых с клавиатуры целых чисел. В языке Паскаль!
Ответы (1)