Задать вопрос
15 августа, 06:25

Помогите с паскалем

1. написать алгоритм нахождения максимального среди 4 целых чисел.

2. написать алгоритм проверки: имеются ли среди трех целых чисел два положительных значения.

3. написать алгоритм проверки: лежит ли точка с координатами х; у в первой координатной четверти?

+3
Ответы (1)
  1. 15 августа, 09:21
    -1
    Var a, b, c: integer;

    begin

    for a : = 1 to 4 do

    begin

    readln (b) ;

    if b > c then c:=b;

    end;

    end.

    var a, b, c: integer;

    begin

    for b:=1 to 3 do

    begin

    readln (a) ;

    if a > 0 then c: = c+1;

    end;

    if c = 2 then write ('est') ;

    end.

    var x, y:integer;

    begin

    readln (x, y) ;

    If (x>0) and (y>0) then writeln ('est') ;

    end.

    Все писал с телефона
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с паскалем 1. написать алгоритм нахождения максимального среди 4 целых чисел. 2. написать алгоритм проверки: имеются ли среди трех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана точка В с координатами x, y. Определить, в какой четверти координатной плоскости лежит данная точка В. Точка с координатами (-5; 5) очень строчно надо помогите соч за 3 четверть
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Решение есть. нужно его объяснить. Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в
Ответы (1)
Опредилить, лежит ли данная точка с координатами х, у в первой четверти координатной плоскости
Ответы (1)