Задать вопрос
30 декабря, 01:30

на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел. Печать результата по вводу 0 (используя цикл while т. е. предусловие).

+2
Ответы (1)
  1. 30 декабря, 05:15
    0
    var

    a, s: real; / / a - вводимое с клавиатуры число, s - сумма чисел

    begin

    a: = 1; / / Присваиваем начальное значение, чтобы цикл выполнился

    s: = 0;

    while a 0 do

    begin

    writeln ('Введите положительное число') ;

    readln (a) ;

    if a < 0 then

    begin

    writeln ('Введено не положительное число. Повторите ввод заново') ;

    continue; {Если а - не положительное число, вводим число заново}

    end;

    s: = s + a;

    end;

    writeln ('Сумма: ', s) ; / / Выводим сумму

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел. Печать результата ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)
Написать программу, используя оператор while, для нахождения суммы любых 10 чисел вводимых с клавиатуры Pascal ABC
Ответы (1)
1. Написать программу на языке программирования Паскаль, для вычисления значения выражения y=5x+6, если х любые числа и вводится с клавиатуры. 2.
Ответы (1)