Задать вопрос
27 ноября, 03:40

Задачи по Паскалю. Условный оператор.

1. Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.

2. Найдите решение уравнения ах + в=0, если оно существует, если а=0

3. написать программу удвоения меньшего из двух чисел

+2
Ответы (1)
  1. 27 ноября, 05:06
    0
    1)

    program chik2;

    var a, b, c:real;

    begin

    readln (a, b) ;

    if (a
    c:=a;

    a: = (a+b) / 2;

    b:=b*c;

    end;

    if (a>=b) then begin

    c:=b;

    b: = (a+b) / 2;

    a:=a*c;

    end;

    writeln (a,' ', b) ;

    end.

    2)

    program chik;

    var a, x, b:real;

    begin

    readln (a, b) ;

    if (a=0) and (b0) then writeln ('НЕТ решений') ;

    if (a0) then begin

    x:=-b/a;

    writeln (x) ;

    end;

    end.

    3)

    program chik3;

    var a, b:real;

    begin

    readln (a, b) ;

    if (a
    if (b
    writeln (a,' ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задачи по Паскалю. Условный оператор. 1. Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Паскале. Даны два числа. Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить блок-схему.
Ответы (1)
Язык C#. Написать программу на языке C#разветвляющейся структуры согласно вариантам задания 1 (используя if) и задания 2 (используя switch). 1. Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2.
Ответы (1)
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)
Даны два числа a и b. Меньшее из них замените полусуммой этих чисел, а большее - произведением этих чисел
Ответы (1)
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)