Задать вопрос
3 августа, 02:32

Написать программу в Паскале. Даны два числа. Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить блок-схему.

+2
Ответы (1)
  1. 3 августа, 03:12
    0
    Var a, b:integer;

    begin

    writeln ('a=') ;

    readln (a) ;

    writeln ('b=') ;

    readln (b) ;

    if (a>b) then begin

    b: = (a+b) / 2;

    a:=a*b;

    end

    else

    begin

    a: = (a+b) / 2;

    b:=a*b;

    end;

    writeln ('a=', a, ' b=', b) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале. Даны два числа. Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны два числа a и b. Меньшее из них замените полусуммой этих чисел, а большее - произведением этих чисел
Ответы (1)
Задачи по Паскалю. Условный оператор. 1. Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2. Найдите решение уравнения ах + в=0, если оно существует, если а=0 3.
Ответы (1)
Язык C#. Написать программу на языке C#разветвляющейся структуры согласно вариантам задания 1 (используя if) и задания 2 (используя switch). 1. Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2.
Ответы (1)
Написать прогу на C# с помощью функции if Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением.
Ответы (1)
Даны два числа. Большее из двух данных чисел заменить удвоенным произведением, а меньшее полусуммой этих чисел.
Ответы (1)