Задать вопрос
24 апреля, 16:24

Напишите программу поиска всех двузначных чисел, в которых есть цифра n или само число делится на n.

+3
Ответы (2)
  1. 24 апреля, 17:35
    0
    Uses crt;

    var a, n:integer;

    begin

    write ('n:') ; readln (n) ;

    if n>=10 then writeln ('error')

    else

    for a:=10 to 99 do

    if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln (a) ;

    end.
  2. 24 апреля, 20:00
    0
    Dim i As Integer

    Dim msg As String

    Dim n As Integer

    n = CInt (InputBox ("Введите n"))

    For i = 10 To 99

    If CStr (i). IndexOf (n) > - 1 Or i Mod n = 0 Then

    msg = msg & i & vbCrLf

    End If

    Next

    MsgBox (msg)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу поиска всех двузначных чисел, в которых есть цифра n или само число делится на n. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Напишите программу поиска все двузначных чисел, в которых есть цифра n, или само число делится на n (решите по паскалю).
Ответы (2)
Помогите решить задачи в С++ 1) Вывести на экран все двузначные числа в которых есть цифра n или само число делится на n. n вводится с клавиатуры.
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)