Задать вопрос
17 октября, 19:02

Задача на тему цикл с параметром Паскаль.

Определить среди 10 чисел какое из них наибольшее и вывести порядковый номер этого числа.

+3
Ответы (1)
  1. 17 октября, 21:37
    0
    Program P;

    Var

    n, i : Integer;

    max, iMax: Integer;

    Begin

    Write ('Enter 10 numbers ') ;

    for i : = 1 to 10 do

    Begin

    Read (n) ;

    if i = 1 then

    Begin

    max : = n;

    iMax : = i;

    End

    else

    if n > max then

    Begin

    max : = n;

    iMax : = i;

    End;

    End;

    WriteLn ('Max = ', max) ;

    WriteLn ('index = ', iMax) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача на тему цикл с параметром Паскаль. Определить среди 10 чисел какое из них наибольшее и вывести порядковый номер этого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
На с + + Мальчик-романтик из царства-государства дарит цветы незнакомым дамам-девушкам. Известно, что он дарит цветок каждой пятой даме-девушке, но при этом не дарит цветок, если порядковый номер дамы-девушки кратен 25.
Ответы (1)
Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)