Задать вопрос
29 апреля, 07:12

Помогите решить задачи в С++

1) Вывести на экран все двузначные числа в которых есть цифра n или само число делится на n. n вводится с клавиатуры.

2) Вывести все трехзначные числа, которые являются палиндромами (одинаково читаются слева направо и наоборот 232, 454)

3) Найти сумму всех двузначных чисел, которые чётные или последняя цифра которых равна 7.

4) Найти количество всех трехзначных чисел, которые в своей записи имеют хотя бы 2 одинаковые цифры.

+3
Ответы (1)
  1. 29 апреля, 09:43
    0
    1)

    #include

    using namespace std;

    int main ()

    {

    int n;

    cout <> n;

    for (int i=10; i<100; i++)

    if ((i/10==n)

    return 0;

    }

    Пример:

    n = 7

    14 17 21 27 28 35 37 42 47 49 56 57 63 67 70 71 72 73 74 75 76 77 78 79 84 87 91 97 98

    2.

    #include

    using namespace std;

    int main ()

    {

    for (int i=1; i<10; i++) {

    for (int j=0; j<10; j++)

    cout << i*100+j*10+i << " ";

    }

    return 0;

    }

    Результат:

    101 111 121 131 ... 979 989 999

    3.

    #include

    using namespace std;

    int main ()

    {

    int s = 0;

    for (int i=10; i<100; i++)

    cout << "s = " << s;

    return 0;

    }

    Результат:

    s = 2943

    4.

    #include

    using namespace std;

    int main ()

    {

    int a, b, c, k = 0;

    for (int i=100; i<1000; i++)

    a = i / 100;

    b = i / 10 % 10;

    c = i % 10;

    if ((a==b)

    cout << "k = " << k;

    return 0;

    }

    Результат:

    k = 252
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи в С++ 1) Вывести на экран все двузначные числа в которых есть цифра n или само число делится на n. n вводится с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Помогите решить 'цикл со счётчиком' по икт. 3 задачи 1. среди двухзначных чисел найти сумму чисел, кратных 5. Сами числа и сумму вывести на экран. 2.
Ответы (1)