Задать вопрос
29 марта, 10:16

Написать программу в Паскале:

1) Вводятся 10 целых чисел. Подсчитать количество четных среди них

2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).

3) Вывести на экран все трехзначные числа-палиндромы, т. е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

+4
Ответы (1)
  1. 29 марта, 12:48
    0
    var

    i, c : byte;

    t : integer;

    begin

    c : = 0;

    for i : = 1 to 10 do

    begin

    read (t) ;

    if t mod 2 = 0 then inc (c) ;

    end;

    writeln (c) ;

    end.

    var

    n, i : integer;

    begin

    read (n) ;

    for i : = 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i) ;

    end.

    var

    i : integer;

    begin

    for i : = 100 to 999 do

    if i mod 10 = i div 100 then writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Петя узнал на уроке английского языка в школе о том, что существуют палиндромы - слова, которые читаются справа налево и слева направо одинаково. Придя на урок математики, он обнаружил, что число 101 тоже палиндром.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)