Задать вопрос
17 июня, 07:53

Написать программу, которая находит и выводит на печать все четырёхзначные числа abcd, для которых выполняется : a, b, c, d - разные цифры ab-cd=a+b+c+d

+5
Ответы (1)
  1. 17 июня, 09:32
    0
    {Задачу можно решать несколькими способами. Одним из возможных способов является перебор всех четырехзначных чисел и проверка для каждого из них выполнения условий. Попробуем сократить перебор, для этого преобразуем второе условие:

    10 а+b - (10c+d) = a+b+c+d;

    9 (a-c) = 2 (c+d) ;

    (a-c) / (c+d) = 2/9

    Проанализировав первое условие, получаем, что а=с+2, d=9-c, следовательно 0<=c<=7.}

    program prim4;

    uses crt;

    var a, b, c, d: integer;

    begin

    clrscr;

    for c:=0 to 7 do

    begin

    a:=c+2; d; =9-c;

    for b:=0 to 9 do

    begin

    if (bc) and (ba) and (bd)

    then

    write (a, b, c, d) ;

    writeln

    end;

    end;

    readln;

    end.

    {Таким образом, мы решили задачу, значительно сократив перебор. }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит и выводит на печать все четырёхзначные числа abcd, для которых выполняется : a, b, c, d - разные цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая находит все четырехзначные числа abcd, для которых выполняются условия 1) a, b, c, d-разные цифры 2) a*b-c*d=a+b+c+d
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)