Задать вопрос
6 января, 19:09

Написать программу, которая находит все четырехзначные числа abcd, для которых выполняются условия

1) a, b, c, d-разные цифры

2) a*b-c*d=a+b+c+d

+1
Ответы (1)
  1. 6 января, 22:56
    0
    Program fofgogjoj;

    var

    a, b, c, d:integer;

    begin

    for c:=0 to 7 do

    begin

    a:=c+2;

    d:=9-c;

    for b:=0 to 9 do

    begin

    if (bc) and (ba) and (bd) then

    Writeln (a, b, c, d) ;

    Writeln;

    end;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит все четырехзначные числа abcd, для которых выполняются условия 1) a, b, c, d-разные цифры 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая находит и выводит на печать все четырёхзначные числа abcd, для которых выполняется : a, b, c, d - разные цифры ab-cd=a+b+c+d
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Написать программу в Паскале. Используя операторы цикла и условия, написать программу, которая из введенных N чисел: 1) Находит и выводит на экран все двухзначные числа, кратные 10 (с циклом mod). 2) Найти сумму всех чисел больше 10.
Ответы (1)