Задать вопрос
15 июня, 04:30

1.

Даны два

натуральных числа M и N - числитель и знаменатель дроби M/N.

Требуется сократить дробь, насколько это возможно.

+5
Ответы (1)
  1. 15 июня, 06:30
    0
    Var n, m, q, i:integer; f:boolean;

    begin

    read (m, n) ;

    f:=true;

    while f=true do begin

    f:=false;

    if m>n then q:=n else q:=m;

    for i:=2 to q do begin

    if (m mod i = 0) and (n mod i = 0) then begin m:=m div i; n:=n div i; f:=true; end;

    end;

    end;

    writeln (m,'/', n) ;

    end.

    По идее так, не проверял.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Даны два натуральных числа M и N - числитель и знаменатель дроби M/N. Требуется сократить дробь, насколько это возможно. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
Паскаль! Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
Даны натуральные числа a и b, обозначающие соответственно числитель и знаменатель дроби. Сократить дробь, т. е. найти такие натуральные числа p и q, не имеющие общих делителей, что p/q=a/b.
Ответы (1)
Знаменатель правильной дроби на 3 больше числителя. если числитель увеличить в 7 раз, а к знаменателю прибавить 8 и сократить полученную дробь, то в результате получится дробь 3/4. найти исходную дробь.
Ответы (1)
Составьте программу, которая запрашивает числитель и знаменатель неправильной дроби и выделяет целую часть (с помощью оператора выбора case) Например: Числитель и знаменатель: 17 3 17/3=5 2/3
Ответы (1)