Задать вопрос
10 ноября, 03:50

Паскаль!

Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3

+3
Ответы (1)
  1. 10 ноября, 04:05
    0
    function Gcd (a, b: longint) : longint;

    { Нахождение НОД }

    var

    i: longint;

    begin

    while b 0 do

    begin

    a : = a mod b;

    i : = b; b : = a; a : = i

    end;

    gcd : = a

    end;

    procedure ShortFraction (var m, n:longint) ;

    var

    k:longint;

    begin

    k:=Gcd (m, n) ;

    m:=m div k; n:=n div k

    end;

    var

    a, b:longint;

    begin

    Write ('Введите числитель и знаменатель дроби: ') ; Readln (a, b) ;

    ShortFraction (a, b) ;

    Writeln ('Дробь после сокращения равна ', a,'/', b)

    end.

    Тестовое решение:

    Введите числитель и знаменатель дроби: 25 15

    Дробь после сокращения равна 5/3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите процедуру которая определяет верно ли что переданное ей число - простое. (Используйте изменяемые параметры)
Ответы (1)