Задать вопрос
13 августа, 18:47

Напишите процедуру которая определяет верно ли что переданное ей число - простое. (Используйте изменяемые параметры)

+3
Ответы (1)
  1. 13 августа, 19:59
    0
    Procedure prime (n: integer) ;

    var i: integer;

    begin

    for i : = 2 to round (sqrt (n)) do

    if n mod i = 0 then

    begin

    writeln ('Число ', n, ' составное') ;

    exit

    end;

    writeln ('Число ', n, ' простое')

    end;

    begin

    prime (3) ;

    prime (8) ;

    prime (23) ;

    prime (35) ;

    end.

    Вывод:

    Число 3 простое

    Число 8 составное

    Число 23 простое

    Число 35 составное
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите процедуру которая определяет верно ли что переданное ей число - простое. (Используйте изменяемые параметры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
Паскаль! Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110
Ответы (1)