Задать вопрос
13 января, 19:09

Даны натуральные числа a и b, обозначающие соответственно числитель и

знаменатель дроби. Сократить дробь, т. е. найти такие натуральные числа p и q, не

имеющие общих делителей, что p/q=a/b. (Написать функцию для расчёта наибольшего

общего делителя двух натуральных чисел, используя алгоритм Евклида).

Функции пользователя. Паскаль.

+3
Ответы (1)
  1. 13 января, 21:57
    0
    Program n1;

    var n, m, d:integer;

    function NOD (n, m:integer) : integer;

    begin

    while nm do if m>n then m:=m-n else n:=n-m;

    nod:=m;

    end;

    begin

    write ('введите числитель: ') ;

    readln (n) ;

    write ('введите знаменатель: ') ;

    readln (m) ;

    writeln ('введена дробь: ', n,'/', m) ;

    d:=nod (n, m) ;

    n:=n div d;

    m:=m div d;

    writeln ('сокращенная дробь: ', n,'/', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа a и b, обозначающие соответственно числитель и знаменатель дроби. Сократить дробь, т. е. найти такие натуральные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на остаток от деления большего на меньшее до тех пор, пока остаток не станет равно нулю;
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Паскаль! Напишите процедуру, которая сокращает дробь вида M/N. Числитель и знаменатель дроби передаются как изменяемые параметры. Пример: Введите числитель и знаменатель дроби: 25 15 После сокращения: 5/3
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)