Задать вопрос
18 октября, 23:44

Найти сумму элементов последовательности с точностью 0,001:

S=1 + 2 / (2*3) - 4 / (3*9) + 6 / (5*27) - 8 / (8*81) + 10 / (13*243) - ...

+4
Ответы (1)
  1. 19 октября, 00:54
    0
    Const

    e = 0.000001;

    var

    i, f, f1, thn, t: integer;

    s, s1: real;

    begin

    i : = 0;

    f1 : = 1;

    f : = 2;

    thn : = - 1;

    s : = 1;

    s1 : = 0;

    repeat

    i : = i + 1;

    s1 : = s;

    thn : = thn * - 3;

    s : = s + 2 * i / f / thn;

    writeln (2 * i, ' ', f, ' ', thn, ' ', s) ;

    t : = f1;

    f1 : = f;

    f : = f + t

    until abs (abs (s1) - abs (s)) < e;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму элементов последовательности с точностью 0,001: S=1 + 2 / (2*3) - 4 / (3*9) + 6 / (5*27) - 8 / (8*81) + 10 / (13*243) - ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (2)
Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены всех ненулевых элементов исходной последовательности на разность между элементом последовательности и найденной
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)