Задать вопрос
9 сентября, 17:21

Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены всех ненулевых

элементов исходной последовательности на разность между элементом последовательности и найденной суммой.

+1
Ответы (1)
  1. 9 сентября, 20:12
    0
    Program Project1;

    var

    a:array[1 ... 5] of Integer;

    i, j, sum:Integer;

    s:string;

    begin

    Readln (s) ;

    sum:=0;

    for i:=1 to 5 do

    begin

    if (Length (s) >=2) then

    begin

    j:=Pos (' ', s) ;

    a[i]:=StrToInt (Copy (s, 1, j-1)) ;

    sum:=sum+a[i];

    Delete (s, 1, j) ;

    end

    else

    begin

    a[i]:=StrToInt (s) ;

    sum:=sum+a[i];

    end;

    end;

    for i:=1 to 5 do

    begin

    if (a[i]0) then

    begin

    a[i]:=a[i]-sum;

    Write (a[i], ' ') ;

    end

    else

    begin

    a[i]:=a[i];

    Write (a[i], ' ') ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)