Задать вопрос
13 марта, 02:50

Дан массив из N чисел. Найти среднее арифметическое элементов, удовлетворяющих условию 2<=[i]<=8. Если таких элементов нет, вывести сообщение об этом.

+3
Ответы (1)
  1. 13 марта, 05:22
    0
    Program zad;

    var i, m:longint;

    sum, count:real;

    A:array [1 ... n] of longint;

    begin

    sum:=0; count:=0;

    for i:=1 to n do

    begin read (m) ; A[i]:=m end;

    for i:=1 to n do

    if (A[i]>=2) and (A[i]<=8)

    then begin sum:=sum+A[i]; count:=count+1 end;

    sum:=sum/count;

    if (sum<0)

    then writeln ('Элементов удовлетворяющих условию нет')

    else writeln (sum) ;

    end.

    P. S. Переменную n во всем тексте программы следует заменить на конкретное натуральное число!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N чисел. Найти среднее арифметическое элементов, удовлетворяющих условию 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)