Задать вопрос
17 декабря, 21:50

1. Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. Напишите программу, которая по введенным координатам двух полей (k, l) и (m, n) определяет, являются ли эти поля полями одного цвета.

Пример входных данных: координаты 1-го поля - 2 2; координаты 2-го поля - 3 3 Пример выходных данных: поля одного цвета

2. Напишите программу, в которой пользователю предлагается дополнить до 100 некоторое целое число а (а - случайное число, меньшее 100). Ответ пользователя проверяется и комментируется.

+5
Ответы (1)
  1. 18 декабря, 00:35
    0
    1.

    var k, l, m, n: integer;

    begin

    readln (k, l, m, n) ;

    if (k+l+m+n mod 2 = 0) then

    writeln ('поля одного цвета')

    else

    writeln ('поля разных цветов')

    end.

    2.

    uses crt; {В зависимости от компилятора эта строчка может оказаться лишней}

    var question, answer: integer;

    begin

    randomize () ;

    question : = random (100) ;

    writeln (question) ;

    readln (answer) ;

    if (question+answer=100) then

    writeln ('Not bad')

    else

    writeln ('Oops. Right answer is ', 100-question)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. Напишите программу, которая по введенным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в которой пользователю предлагается дополнить до 100 некоторое число a (a - случайное число, меньшее 100) ответ пользователя проверяется и комментируете
Ответы (1)
Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей выясните являються эти поля одного цвета
Ответы (1)
Делфи. Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8: первое число - номер вертикали (при счете слева направо), второе - номер горизонтали (при счете снизу-вверх).
Ответы (1)
Написать программу, в которой пользователю предлагаетсядополнить до 100 некоторое целое число а (а - случайное число, меньшее 100).
Ответы (2)
Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки) Одного ли цвета эти клетки на шахматной доске? Вывести в выходной файл сообщение YES, если они одного цвета, и NO иначе
Ответы (2)