Задать вопрос
21 декабря, 01:56

Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки) Одного ли цвета эти клетки на шахматной доске? Вывести в выходной файл сообщение YES, если они одного цвета, и NO иначе

+3
Ответы (2)
  1. 21 декабря, 02:06
    0
    1 2 3 4 5 6 7 8 9 10 11 #include using namespace std; int main () { freopen ("input. txt","r", stdin) ; freopen ("output. txt","w", stdout) ; int x1, y1, x2, y2; cin>>x1>>y1>>x2>>y2; if ((x1+y1) %2 = = (x2+y2) %2) cout<<"YES"; else cout<<"NO"; return 0; }
  2. 21 декабря, 05:26
    0
    Var

    a, b : array[1 ... 8, 1 ... 8]of integer;

    i, j, k, x, y, x1, y1:integer;

    begin

    k:=-1;

    for i: = 1 to 8 do

    begin

    k:=-k;

    for j: = 1 to 8 do

    begin

    a[i, j]:=k;

    b[i, j]:=k;

    k: = - k;

    end;

    end;

    Readln (x, y) ;

    Readln (x1, y1) ;

    if (a[x, y] = b[x1, y1]) then Writeln ('YES')

    else Writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки) Одного ли цвета эти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как решить задачу - Даны координаты двух полей шахматной доски. Координаты клетки - это два числа от 1 до 8: номер столбца и номер строки. Одного ли цвета эти клетки на шахматной доске? Надо сделать в Паскале
Ответы (1)
Клетка на шахматной доске задаётся номером строки и номером столбца. Составьте программу, которая определяет, одинакового ли цвета две клетки шахматной доски (а1, b1) и (a2, b2). Значения а1, b1 и a2, b2 вводятся с клавиатуры.
Ответы (1)
Решить задачу на языке Питон " Шахматный ферзь ходит по диагонали, горизонтали или вертикали. Даны две различные клетки шахматной доски, определите, может ли ферзь попасть с первой клетки на вторую одним ходом.
Ответы (1)
Помогите решить (python 3.1) Шахматная ладья ходит по горизонтали или вертикали. Даны две различные клетки шахматной доски, определите, может ли ладья попасть с первой клетки на вторую одним ходом.
Нет ответа
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Ответы (1)