Задать вопрос
13 ноября, 08:04

Как решить задачу - Даны координаты двух полей шахматной доски. Координаты клетки - это два числа от 1 до 8: номер столбца и номер строки. Одного ли цвета эти клетки на шахматной доске? Надо сделать в Паскале

+2
Ответы (1)
  1. 13 ноября, 09:46
    0
    Var x1, y1, x2, y2:integer;

    begin

    write ('Первое поле:') ;

    readln (x1, y1) ;

    write ('Второе поле:') ;

    readln (x2, y2) ;

    if ((x1+y1) mod 2) = ((x2+y2) mod 2)

    then writeln ('Поля имеют одинаковый цвет')

    else writeln ('Поля имеют разный цвет') ;

    end.

    Пример:

    Первое поле: 2 3

    Второе поле: 7 5

    Поля имеют разный цвет
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как решить задачу - Даны координаты двух полей шахматной доски. Координаты клетки - это два числа от 1 до 8: номер столбца и номер строки. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки) Одного ли цвета эти клетки на шахматной доске? Вывести в выходной файл сообщение YES, если они одного цвета, и NO иначе
Ответы (2)
Клетка на шахматной доске задаётся номером строки и номером столбца. Составьте программу, которая определяет, одинакового ли цвета две клетки шахматной доски (а1, b1) и (a2, b2). Значения а1, b1 и a2, b2 вводятся с клавиатуры.
Ответы (1)
Решить задачу на языке Питон " Шахматный ферзь ходит по диагонали, горизонтали или вертикали. Даны две различные клетки шахматной доски, определите, может ли ферзь попасть с первой клетки на вторую одним ходом.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Помогите решить (python 3.1) Шахматная ладья ходит по горизонтали или вертикали. Даны две различные клетки шахматной доски, определите, может ли ладья попасть с первой клетки на вторую одним ходом.
Нет ответа