Задать вопрос
27 мая, 21:39

Написать программы в Паскале

• Дан массив из N вещественных чисел. Поменять местами последний и минимальный элементы массива.

• Дан массив из N целых чисел. Найти номер первого элемента, который равен количеству элементов, кратных 3.

+4
Ответы (1)
  1. 27 мая, 22:16
    0
    Program task1;

    const

    n = 10;

    var

    a : array [1 ... n] of real;

    i, j : integer;

    min, k : real;

    begin

    for i: = 1 to n do

    readln (a[i]) ;

    min: = a[1];

    for i: = 1 to n do

    if a[i] < min then

    begin

    min: = a[i];

    j: = i;

    end;

    k: = a[n];

    a[n]: = a[j];

    a[j]: = k;

    end.

    program task2;

    const

    n = 10;

    var

    a : array [1 ... n] of integer;

    i, j, kol : integer;

    begin

    for i: = 1 to n do

    readln (a[i]) ;

    kol: = 0;

    for i: = 1 to n do

    if a[i] mod 3 = 0 then

    inc (kol) ;

    for i: = 1 to n do

    if a[i] = kol then

    begin

    j: = i;

    break;

    end;

    writeln (j) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программы в Паскале • Дан массив из N вещественных чисел. Поменять местами последний и минимальный элементы массива. • Дан массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)