Задать вопрос
14 января, 00:05

Вводите по очереди данные в росте N учащихся класса. Определить средний рост учащихся в классе

+5
Ответы (1)
  1. 14 января, 01:31
    0
    Var i, sum, m, pr:real;

    begin

    i:=1; m:=-1;

    writeln ('Вводите рост учеников, когда закончите введите 0.') ;

    while (i0) do begin

    readln (i) ;

    sum:=sum+i;

    m:=m+1;

    end;

    pr:=sum/m;

    writeln ('Средний рост:', pr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводите по очереди данные в росте N учащихся класса. Определить средний рост учащихся в классе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на языке прлграммирования Pascal. В компьютер вводятся по очереди данные о росте N учащихся класса. Определить средний рост учащихся класса.
Ответы (2)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите составить программы на Си++ 1. Написать функцию, которая находит среднее арифметическое всех элементов (целые числа) непустого списка L, сформированного по принципу стека. 2. В компьютер вводятся по очереди данные о росте N учащихся класса.
Ответы (1)
Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.
Ответы (1)
Решить задачу циклом For с использованием массива: Ввести данные о весе и росте N учащихся 9 класса. Определить средние вес и рост учащихся в классе.
Ответы (1)