Задать вопрос
8 марта, 18:50

Помогите написать программу на Паскале

Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.

+5
Ответы (1)
  1. 8 марта, 19:38
    0
    Var n, i, growth, growth_girls, growth_boys, count_boys, count_girls: integer;

    begin

    writeln ('Введите количество учеников в классе') ;

    read (n) ;

    growth_girls : = 0;

    growth_boys : = 0;

    count_boys : = 0;

    count_girls : = 0;

    for i : = 1 to n do

    begin

    read (growth) ;

    if (growth < 0) then

    begin

    growth_boys : = growth_boys - growth;

    count_boys : = count_boys + 1;

    end

    else

    begin

    growth_girls : = growth_girls + growth;

    count_girls : = count_girls + 1;

    end;

    end;

    if (count_boys = 0) then

    writeln ('В классе нет мальчиков')

    else

    writeln ('Средний рост мальчиков: ', (growth_boys / count_boys) : 0:2) ;

    if (count_girls = 0) then

    writeln ('В классе нет девочек')

    else

    writeln ('Средний рост девочек: ', (growth_girls / count_girls) : 0:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Известен рост каждого ученика группы. Рост мальчиков задан отрицательными числами. Верно ли, что средний рост мальчиков не превышает рост девочек более чем на 10 см?
Ответы (1)
Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе. Всё делать при помощи массива
Ответы (1)
Написать программу на заполнение 2-х массивов (рост девочек и рост мальчиков). Определить средний рост мальчиков. Подсчитать количество девочек, у которых рост выше среднего роста мальчиков.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
В одном автобусе ехали 20 мальчиков, в другом - 20 девочек. Автобусы встретились. Пять мальчиков перешли в автобус девочек, а потом столько же детей перешли из автобуса девочек в автобус мальчиков.
Ответы (1)