Задать вопрос
9 сентября, 21:58

Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе.

Всё делать при помощи массива

+2
Ответы (1)
  1. 9 сентября, 23:53
    0
    Const n=10;

    var a: array[1 ... n] of integer;

    i, k: integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to n do begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if a[i]>0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Исходный массив:

    a[1]=168

    a[2]=156

    a[3]=155

    a[4]=-176

    a[5]=154

    a[6]=-175

    a[7]=-173

    a[8]=174

    a[9]=164

    a[10]=-170

    k = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе. Всё делать при помощи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.
Ответы (1)
Известен рост каждого ученика группы. Рост мальчиков задан отрицательными числами. Верно ли, что средний рост мальчиков не превышает рост девочек более чем на 10 см?
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)