Задать вопрос
19 марта, 18:08

Известен рост каждого ученика группы. Рост мальчиков задан отрицательными числами. Верно ли, что средний рост мальчиков не превышает рост девочек более чем на 10 см?

+2
Ответы (1)
  1. 19 марта, 20:41
    0
    Var

    m, d, x:real;

    n, nm, i:integer;

    begin

    write ('Сколько учеников:') ;

    readln (n) ;

    for i:=1 to n do

    begin

    readln (x) ;

    if x<0 then

    begin

    m:=m+x;

    nm:=nm+1

    end

    else d:=d+x;

    end;

    m:=-m/nm;

    d:=d / (n-nm) ;

    writeln;

    if m-d<=10 then writeln ('Да, верно')

    else writeln ('Нет, неверно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известен рост каждого ученика группы. Рост мальчиков задан отрицательными числами. Верно ли, что средний рост мальчиков не превышает рост ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.
Ответы (1)
Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе. Всё делать при помощи массива
Ответы (1)
Написать программу на заполнение 2-х массивов (рост девочек и рост мальчиков). Определить средний рост мальчиков. Подсчитать количество девочек, у которых рост выше среднего роста мальчиков.
Ответы (1)
В одном автобусе ехали 20 мальчиков, в другом - 20 девочек. Автобусы встретились. Пять мальчиков перешли в автобус девочек, а потом столько же детей перешли из автобуса девочек в автобус мальчиков.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)