Задать вопрос
14 сентября, 05:45

Написать программу на заполнение 2-х массивов (рост девочек и рост мальчиков). Определить средний рост мальчиков. Подсчитать количество девочек, у которых рост выше среднего роста мальчиков.

+1
Ответы (1)
  1. 14 сентября, 08:53
    0
    unit math;

    var

    d, m:array[1 ... 20] of integer;

    sr:real;

    kol, s:integer;

    Begin

    for i:=1 to 20 do begin

    d[i]:=RandomRange (140,180) ;

    writeln ('Рост ', i,'-ой девочки = ', d[i],' см') ;

    m[i]:=RandomRange (140,190) ;

    writeln ('Рост ', i,'-го мальчика = ', m[i],' см') ;

    end;

    s:=0; sr:=0; kol:=0;

    for i:=1 to 20 do s:=s+m[i];

    sr:=s/20;

    writeln ('Средний рост мальчиков = ', sr,' см') ;

    for i:=1 to 20 do

    if d[i]>sr then kol:=kol+1;

    writeln ('Колличество девочек превышающий средний рост мальчиков = ', kol) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на заполнение 2-х массивов (рост девочек и рост мальчиков). Определить средний рост мальчиков. Подсчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу на Паскале Известен рост каждого ученика в классе. Рост мальчиков условно задан отрицательными числами. Определить средний рост мальчиков и средний рост девочек.
Ответы (1)
1. Описать массив, подходящий для представления роста (в см) призывников в РА из 115 группы. 2. Написать программу, заполняющую массив данными (не упорядоченными) с клавиатуры и печатающую средний рост призывников. 3.
Ответы (1)
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
Составить программу для решения задачи: Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых больше среднего роста по классу.
Ответы (1)
1. Количество единиц среди элементов массива. Заполнение массива произвести с клавиатуры. 2. Ко всем отрицательным элементам массива прибавить первый элемент. Заполнение массива произвести случайными целыми числами из [ - 6,6]
Ответы (1)