Задать вопрос
25 сентября, 22:31

Составить программу для решения задачи:

Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых больше среднего роста по классу.

+1
Ответы (1)
  1. 26 сентября, 01:53
    0
    Const n = 25;

    var

    rost : array [1 ... 25] of byte;

    count, i : byte;

    sum: integer;

    begin

    randomize;

    for i:=1 to 25 do

    begin

    rost[i]:=random (40) + 150;

    inc (sum, rost[i]) ;

    end;

    for i:=1 to 25 do

    if rost[i]> (sum/n) then inc (count) ;

    write (count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для решения задачи: Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Написать программу на заполнение 2-х массивов (рост девочек и рост мальчиков). Определить средний рост мальчиков. Подсчитать количество девочек, у которых рост выше среднего роста мальчиков.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)