Задать вопрос
12 августа, 21:00

1. Количество единиц среди элементов массива. Заполнение массива произвести с клавиатуры.

2. Ко всем отрицательным элементам массива прибавить первый элемент. Заполнение массива произвести случайными целыми числами из [ - 6,6]

+2
Ответы (1)
  1. 12 августа, 23:07
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    k:=0;

    Write ('Введите массив A (', N,') : ') ;

    For i: = 1 to N do

    Begin

    Read (A[i]) ;

    if A[i] = 1 then k:=k+1

    End;

    WriteLn ('Количество единиц: ', k) ;

    End.

    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    Begin

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (13) - 6;

    Write (' ', A[i]) ;

    if A[i] < 0 then A[i]:=A[i]+A[1]

    End;

    WriteLn;

    Write ('Новый массив:') ;

    For i: = 1 to N do

    Write (' ', A[i])

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Количество единиц среди элементов массива. Заполнение массива произвести с клавиатуры. 2. Ко всем отрицательным элементам массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Найти сумму всех элементов массива целых чисел, которые меньше среднего арифметического элементов массива. Размерность массива-20. Заполнение массива осуществить случайными числами от 150 до 300
Ответы (1)