Задать вопрос
14 января, 03:27

Дан массив целых чисел из 44 элементов, заполненный случайным образом числами из промежутка [-18; 30]. Вывести на экран элементы с 13 по 26!

+4
Ответы (1)
  1. 14 января, 06:56
    0
    Var mass:array[1 ... 44] of integer;

    i:integer;

    begin

    randomize;

    for i:=1 to 44 do

    begin

    mass[i]: = (random (31) - random (19)) ;

    if (i>12) and (i<27) then writeln ('номер ', i,' равен ', mass[i]) ;

    end;

    end.

    Пример работы:

    номер 13 равен 15

    номер 14 равен - 17

    номер 15 равен - 16

    номер 16 равен - 3

    номер 17 равен 10

    номер 18 равен 29

    номер 19 равен - 17

    номер 20 равен 1

    номер 21 равен - 1

    номер 22 равен 8

    номер 23 равен - 16

    номер 24 равен 26

    номер 25 равен - 4

    номер 26 равен 15
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из 44 элементов, заполненный случайным образом числами из промежутка [-18; 30]. Вывести на экран элементы с 13 по 26! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)