Задать вопрос
31 декабря, 03:27

Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое нечётных чисел. Программа получает на вход целые положительные числа. Количества введенных чисел не известно.

+5
Ответы (1)
  1. 31 декабря, 03:38
    0
    uses crt;

    var i, sum, k: integer;

    begin

    sum:=0;

    k:=0;

    writeln ('Вводите числа. 0 - конец последовательности') ;

    repeat

    read (i) ;

    if i mod 2=1 then begin

    sum:=sum+i;

    inc (k) ;

    end;

    until i=0;

    writeln;

    writeln ('Среднее арифметическое нечетных чисел: ', sum/k:5:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое нечётных чисел. Программа получает на вход ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)