Задать вопрос
30 мая, 06:40

Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. Программа должна вывести два числа количество и сумму нечетных чисел кратных 5.

+3
Ответы (1)
  1. 30 мая, 10:05
    0
    Var

    A, k, n:integer;

    S:real;

    Begin

    S:=0;

    k:=0;

    Write ('n = ') ; ReadLn (n) ;

    For n: = 1 to n do

    Begin

    Read (A) ;

    if (A mod 5 = 0) and (A mod 2 0) then

    Begin

    S:=S+A;

    k:=k+1

    End;

    End;

    WriteLn ('k = ', k) ;

    WriteLn ('S = ', S) ;

    End.

    Пример работы программы:

    n = 7

    5

    15

    95

    97

    90

    98

    0

    k = 3

    S = 115
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (2)