Задать вопрос
24 мая, 17:28

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число - сумму чисел, кратных 3.

(Pascal)

+4
Ответы (2)
  1. 24 мая, 20:09
    0
    Program n1;

    Uses CRT;

    Var s, i: integer;

    begin

    ClrScr;

    Writeln ('Введите последовательность. Для остановки введите 0 ') ;

    Repeat

    readln (i) ;

    If (i mod 7=0) or (i mod 10=0) then s:=s+i;

    until i=0;

    writeln ('Сумма = ', s) ;

    readln

    end.
  2. 24 мая, 20:29
    0
    uses crt;

    var a:array[1 ... 300] of integer;

    i, s, n, k:integer;

    begin

    clrscr;

    s:=0;

    write ('n=') ;

    read (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if (a[i] mod 3=0) then s:=s+a[i];

    end;

    writeln ('s=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)