Задать вопрос
2 июля, 02:42

Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000 р

+1
Ответы (1)
  1. 2 июля, 05:13
    0
    Var

    a: real;

    begin

    while a < = 1000 do

    begin

    writeln ('Введите сумму покупки > 1000 р') ;

    readln (a) ;

    if a > 1000 then break

    else writeln ('Ошибка! Введенная сумма покупки < = 1000p') ;

    end;

    writeln ('Стоимость покупки с учетом скидки 10%: ', a * 0.9) ;

    end.

    Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:

    var

    a: real;

    begin

    writeln ('Введите сумму покупки > 1000 р') ;

    readln (a) ;

    writeln ('Стоимость покупки с учетом скидки 10%: ', a * 0.9) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000 р ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)
Составить алгоритм для решения задачи и определить его вид. Вычислить стоимость покупки с учётом скидки. Скидка 3% представляется в случае если сумма покупки больше 500 рублей, в 5% если сумма больше 1000 рублей.
Ответы (1)
1. определить, есть ли среди цифр заданного трехзначного числа одинаковые. 2. вычислить стоимость покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 руб.
Ответы (1)
Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.
Ответы (1)