Задать вопрос
25 ноября, 11:20

Напишите программу, запрашивающую три стороны треугольника А, В, С и вычисляющую его площадь по формуле Герона

+1
Ответы (1)
  1. 25 ноября, 14:04
    0
    Если паскаль, то форму сам знаешь как, наверное вот тебе тело.

    var p, S, AB, BC, AC : real (если не работает, то Integer) ;

    begin

    readln (AB) ;

    readln (BC) ;

    readln (AC) ;

    p: = (AB+BC+AC) / 2;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    Writeln (s)

    end.

    Поправь там знаки или ещё что-нибудь - я не в программе писал.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, запрашивающую три стороны треугольника А, В, С и вычисляющую его площадь по формуле Герона ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)